Saturday, April 06, 2013

Lubuntu & The VERY Old Machines - Part 1

Hi,First of all, I'm not a developer and not even close so I will explain as a Lubuntu User :)

I know that starting from 12.04, people started to raise some concerns and sometimes, complaints.
May I explain what is really going on?

As you all know, Lubuntu is based on Ubuntu. Ubuntu is a Linux Distribution after all that is using Linux Kernel.
When Linus Torvalds ( and probably his team release a new version of Linux Kernel, as you may know, with each newer version, new drivers, etc are being added but on the other hand, some are being removed.

Why do we keep Lubuntu 10.04 on our Wiki Area and Servers so you can download it and using it? simply because the Kernel that is being used there does support some old hardware while the NEW version can not.

Linux Kernel version 3.5 -
This is not in our hands.
So, assuming (for example) this Kernel will be with 13.04 or 13.10, we have nothing to do with the fact that this Kernel does not support this or that hardware.

I hope this is clear.
That is why, sometimes, two versions of Lubuntu become different sometimes. Like 12.04 and 11.10 when it comes to drivers, etc.

Hope this will help for a better understanding :)

Thank you so much for reading!

To read Part 2, please click here: Part 2


  1. How sad is this, that for every step forward the Linux Kernel loses one foot step?
    It's A SHAME that Linux (Or Ubuntu?) it's losing compatibility with old hardware...
    My Pentium 3 machine, one that works awesome with Lubuntu 10.04, doesn not work well with 12.04... and I have no hopes for future releases...
    So, what's so real point of distros like Lubuntu? Choice of interface? I must admit that Lubuntu is snappier than Ubuntu and every other Distro of the Ubuntu family... but it lacks of many things that his "father" comes with...
    So, really... keep on Lubuntu for the choice, but since it's useless for old hardware... I keep off of using Lubuntu or every other Linux distro for my Old (but cool) machine. Stucked with Windows XP again! Sad but true :'(

  2. WOW, you got that one totally wrong my friend.
    First of all, Lubuntu or the other 320 active distributions out there are using nothing but a Linux Kernel so whatever changes that happen to the Kernel, neither Lubuntu Developers nor any other Developers can do something about it, unless they create something else rather than Linux. I hope you see my point here.

    I'm not saying on that post that Linux will forsake all the old machines. But, for one minute, let's be realistic here, shall we?
    We are in 2013 right now. If you still can use your machine made in 2000 or before, that is a miracle if you ask me. 13 years, and you still can use that machine. That is a very positive thing and hey, guess what? that machine, made in 2000, are running a system that is made in 2013 :D can you believe this? there is no other system in the world can do that except Linux with all the features that it has. Forget Lubuntu now, we are talking about Linux.

    Now, here is a trade-off. If you still want to use Linux on such machines, just use an old Kernel. What is the point to use a new one if it does not support your machine?
    Kernel 3.2 series should still support some old machines and if not, you can use an older version but don't expect to have all the security updates, etc.

    Don't look at it from the empty half, look at it from the full half of the glass or the bright side ;)

  3. Is it possible to use a new version of Lubuntu (like 12.04) with an old version of the kernel? I know that sometimes kernel upgrades happen within a release, and you can continue using the older kernel, so is it possible to go back a kernel?

    1. Hi,
      There is a way to use newer Kernel on 12.04 for example but what is the point? for example:
      If you want to use Kernel 3.8 on 12.04, you need to install (manually) Kernel version 3.8 and that would be almost the same as using 13.04 which shipped with Linux Kernel 3.8 already :)

      As for using an old kernel, again, what is the point and what you are trying to achieve? because for example, if you will use Kernel version 3.0, I'm not sure if you will still get the security updates for your kernel or not?

      IMHO, there must be a very good reason for using different version and how to do that :)